15 ноября 2013 г.

Настройка туннеля 6to4 на Mikrotik

Перед началом нужно убедиться, что имеется постоянный белый внешний IP и Mikrotik пингуется из интернета. Без этих двух условий дальше можно не продолжать.

1. Регистрируемся у туннельного брокера http://tunnelbroker.net/
2. Создаем туннель (Create Regular Tunnel)
3. Заходим в Tunnel Details
Параметры туннеля
Детали туннеля
Параметры туннеля:
  • Server IPv4 Address: 216.66.80.30
  • Server IPv6 Address: 2001:470:fdea:12df::1/64
  • Client IPv4 Address: 10.10.10.10
  • Client IPv6 Address: 2001:470:fdea:12df::2/64
  • Routed /64: 2001:470:fdeb:12de::/64
4. В консоли Mikrotik'a вводим следующие команды:

  • Создаем интерфейс 6to4:

/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address=10.10.10.10 mtu=1280 name=sit1 remote-address=216.66.80.30


  • Создаем маршрут в IPv6

/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:fdea:12df::1 scope=30 target-scope=10


  • Задаем внешний IPv6 адрес роутера 
/ipv6 address add address=2001:470:fdea:12df::2/64 advertise=no disabled=no eui-64=no interface=sit1


  • Задаем внутренний IPv6 адрес роутера на интерфейсе bridge-local
/ipv6 address add address=2001:470:fdeb:12de::1/64 advertise=yes disabled=no eui-64=no interface=bridge-local

5. В состоянии соединения появится доступ в интернет через IPv6


6. Тесты Google, test-ipv6.com